Customer service page unavailable
Incident Report for Mention Me Ltd
Resolved
The issue with the broken pages has been resolved. All systems are back to normal.

We apologise for any inconvenience caused.
Posted Aug 01, 2023 - 11:37 UTC
Identified
We've identified a problem which has caused the new Customer Service homepage and some parts of the Overview homepage to break.

Approvals and recent customer activity are currently unavailable for the new customer service section, and some metrics are broken on the Overview.

Opting out of the beta customer service section and switching to the old pages will allow you to continue to see activity and approvals.

We have identified the cause and a fix is rolling out now.

We expect resolution in approximately 15 minutes.
Posted Aug 01, 2023 - 11:22 UTC
This incident affected: Client Portal.