Consumer Journey Issues
Incident Report for Mention Me Ltd
Resolved
We are now confident the issue has been resolved. If you notice anything which you think is untoward please contact hello@mention-me.com.
Posted Mar 07, 2024 - 19:28 UTC
Monitoring
We've identified an issue with the Consumer Journey and have reversed an earlier change. We believe this has fixed the issue and we continue to monitor for any further issues.

We will provide another update by 20:00 GMT.
Posted Mar 07, 2024 - 19:04 UTC
Investigating
We're investigating reports of problems with the Consumer Journey for end users of Mention Me. We will have an update available shortly.
Posted Mar 07, 2024 - 18:43 UTC
This incident affected: Consumer Journey.