Voucher Fulfilment Failure
Incident Report for Mention Me Ltd
Resolved
We are confident we have now resolved this issue. If you have any further issues please email support@mention-me.com
Posted Jan 19, 2024 - 11:18 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 19, 2024 - 11:17 UTC
Monitoring
We can confirm the issue arose from a change that was deployed this morning. We have now reversed that change and we are monitoring to confirm the issue has been resolved.
Posted Jan 19, 2024 - 11:08 UTC
Identified
We're aware of an issue fulfilling vouchers and this may also result in some parts of the platform performing slower than normal. We believe we have identified the issue and we are working on deploying a fix.

Next update will be provided by 11:30 GMT.
Posted Jan 19, 2024 - 10:56 UTC
This incident affected: Client Portal and Consumer Journey.