Platform Error Rate Increased
Incident Report for Mention Me Ltd
Resolved
This incident has been resolved. The platform is working normally.
Posted May 11, 2023 - 16:45 UTC
Monitoring
We've identified the source of the problem and deployed a fix. We're monitoring recovery of systems now.
Posted May 11, 2023 - 16:16 UTC
Investigating
We're investigating reports of problems with both the Consumer and Client Journeys for end users of Mention Me. We will have an update available shortly.
Posted May 11, 2023 - 16:02 UTC
This incident affected: Client Portal and Consumer Journey.